powerofthree's Papyrus Extender | Расширение Папируса для Skyrim SE-AE
05.08.2022 31000 7714 Автор мода: powerofthree Автор публикации: k©קaso√® Версия: 5.2.0 Перевод: Мультиязычный

powerofthree's Papyrus Extender | Расширение Папируса для Skyrim SE-AE

Этот плагин своего рода модерский ресурс, содержащий в себе функциональные возможности и расширение Папируса в игре Skyrim SE-AE, которые будут использоваться в моих модах и в модах от других авторов (ниже указан список модов которые требуют наличие данного плагина).

Моды которые требуют наличие этого расширения папируса:
Custom Light
Dark Face Fix Spell SSE (есть у нас на сайте)
Diziet's Auto Outfits
Dragon Age Spells Redux (есть у нас на сайте)
Frozen Electrocuted Combustion 2.6 и выше (есть у нас на сайте)
Hotkey Auto Cast
iEquip (есть у нас на сайте)
Immersion and Lore Continuity - Additions and Tweaks
MCM Cheat Menu
Oblivion Styled Leveling and Attributes
In-Game Equipment Editor SE
Pickpocket Everyone (supports mod-added creatures)
Spellshaping - Magic Customization 2.3.2 и выше
Strange Runes - Spellcasting Enhanced (есть у нас на сайте)
Take All Loose Gold and Arrows
iNeed Universal Water Patch (есть у нас на сайте)
Weighted Arrows SE
* и куча других модов (все моды которые требуют наличие данного папируса смотрите на странице на Нексусе в спойлере Requirements в разделе Mods requiring this file

Примечания и сведения для авторов модов:(для рядового игрока это малополезная информация)
* GetHair/SkinColor теперь возвращает colorform (цветовую форму) вместо того, чтобы требовать ее передачи в функцию.
* Все новые функции добавления/удаления теперь сериализуются с использованием skse cosave (совместные сохранения игры при использовании с SKSE64).
* Функции Add/RemoveBasePerk можно использовать для добавления/удаления перков к NPC во время выполнения, однако удаление добавленных перков не приведет к удалению эффекта перка для уникальных актеров, по крайней мере, до сброса актера.
* GetRandomFloat/Int примерно в 1000 раз быстрее, чем ванильный функционал Utility.RandomFloat/Int
* Функции SetSkinColor должны использоваться только на NPC, и только если это действительно необходимо. Побочным эффектом является потеря цвета губ / красок / шрамов.
* SetFace/SkinTextureSet приведет к шейному шву, если будет заменен весь набор текстур.
* Большинство функций Set actor длятся только один игровой сеанс и могут сохраняться, даже если загрузка сохранится до вызова функции.
* Дополнительная документация для модмейкеров представлена в файле po3_SKSEFunctions.psc

Требования:
Skyrim SE от 1.5.97.0.8 и ниже
SKSE64 SE 2.0.20
Address Library for SKSE Plugins SE 2.0
Visual C++ Redistributables (2015-2022)

Требования:
Skyrim АE от 1.6ххх и выше
SKSE64 AE от 2.1.0 и выше (в соответствии с вашей версией игры)
Address Library for SKSE Plugins AE 5.0 и выше
Visual C++ Redistributables (2015-2022) (ссылка выше та же самая)

При обновлении до версии 3.0 и выше:
* файл po3_papyrusextender64.dll переименован в po3_PapyrusExtender.dll, поэтому при обновлении не забудьте удалить файл po3_papyrusextender64.dll по пути Data/skse/plugins/, если такой у вас имеется. В остальном же при обновлении с предыдущей версии до новой, просто удалить старую версию, установить новую.

Установка:
1. Скачиваем архив "Papyrus Extender"
2. Установить с помощью менеджеров модов с вариантом выбора для SE или АЕ или вручную:
* в архиве из папки 1.5 (для SE) или 1.6 (для АЕ) берем папку SKSE и помещаем в папку Data в игре
* в архиве берем папку scripts (папка sourse не нужна, это для мододелов) и помещаем в папку Data в игре, подтвердить слияние файлов при совпадении.
3. Активация не требуется.

Обновление:5.2.0
* Что обновлено или изменено пока не известно, автор не предоставил список обновления, как появится, добавлю.

Обновление:5.1.1
[События] Исправлена ​​ошибка, из-за которой использование ключевых слов в OnHitEx и OnMagicEffectApplyEx могло привести к тому, что события не срабатывали.

Обновление:5.1.0
[Актёры] Добавлен параметр GetEquippedWeaponPoison и связанные с ним функции.
[Обнаружение] IsDetectedByAnyone — пропускает актеров (НПС) с флагом DoesntAffectStealthMeter.
[События] Добавлен параметр RegisterForHitEventEx (событие попадания с пользовательскими фильтрами, аналогично OnMagicEffectApplyEx).
[События] Добавлены формы уникальных событий (например, RegisterForMagicEffectApplyEx, для этого требуется скрипт, расширяющий ObjectReference).
[Фракция] Добавлен параметр GetVendorFactionContainer.
[Ссылочные данные на объект] Добавлен параметр RemoveAllModItems.
[Общее] Внесена незначительная оптимизация.

Журнал изменений:
* Список изменений всех предыдущих версий читайте в файле Changelogs.txt в архиве.
Внимание: Автор данной темы имеет право удалять комментарии пользователей, если комментарии не соответствуют правилам сайта. Если ВЫ как пользователь считаете, что ваш комментарий был удален без каких-либо на то причин и без основания, то можете написать автору данной темы, и спросить, за что был удален ВАШ комментарий, с предоставлением причины удаления, исходя от правил сайта.
1 2 »
Аватар Lyrfox
Lyrfox в 21:31:07, 06.08.2022
Прошу сказать ясно и точно мод powerofthree's Tweaks надо устанавливать , или можно без него т е может ли он быть причиной зависания анимации в кузне , плавильне , точильном круге , столе зачарований и алхимии ( начинается крафт и всё виснет намертво и выйти из игры невозможно , только через выход Виндоус 10 ивход , без перезагрузки ) ???  meeting
Аватар k©קaso√®
k©קaso√® в 22:09:08, 06.08.2022
№45, Администратор
powerofthree's Tweaks является обязательным требованием, по крайне мере у автора так указано ) насчет остального почему вас так не знаю, НО оказывается у меня установлен данный мод powerofthree's Papyrus Extender и нет powerofthree's Tweaks и игра работает, но я не знаю работает ли вообще сам powerofthree's Papyrus Extender wacko
Аватар viconia
viconia в 12:55:58, 07.08.2022
У меня тоже так было, я не увидела что нужен еще этот твикс. Этот мод нужен для Рун, не знаю работало ли это расширение папируса, но руны у меня работали . Сейчас поставила этот твикс, руны еще не проверяла, но игра не видит один из модов, которые я раньше ставила без проблем. В нем нет ничего такого, просто раширяет общение с НПС, не устанавливается и точка) Не появляется МСМ в игре. Может и не он виноват, надо опять все переустанавливать что бы проверить.
Аватар k©קaso√®
k©קaso√® в 11:09:38, 08.08.2022
№50, Администратор
удалил из требований powerofthree's Tweaks smile
Аватар utimusipusi2
utimusipusi2 в 23:05:03, 07.08.2022
дорогой k©קaso√®  , powerofthree's Tweaks автор поставил в "требуемые" по каким-то своим соображениям, может для "рекламы", без него powerofthree's Papyrus Extender прекрасно работает!  (много раз начинал игру без powerofthree's Tweaks )
powerofthree's Papyrus Extender - это же просто расширение команд "станартного" Папируса
Аватар viconia
viconia в 21:25:45, 05.08.2022
powerofthree's Tweaks обязательно нужен? Он там что то делает с окровавленными объектами.  Он мне поломает моды на кровь наверное.
Аватар utimusipusi2
utimusipusi2 в 22:04:44, 05.08.2022
viconia, в начале описания дан список модов, к которым этот мод Papyrus Extender  ОБЯЗателен, если у вас их нет - зачем вы его ставите себе?)
powerofthree's Tweaks, опираясь на Papyrus Extender, исправляет некоторые ошибки ( список там )
Аватар viconia
viconia в 04:23:03, 06.08.2022
У мен6я есть Руны, и они мне нравятся.
Аватар utimusipusi2
utimusipusi2 в 16:58:28, 06.08.2022
тогда выход простой - открыть Блокнот (лучше  Notepad++ ) и отредактировать строчку

Skinned Decal Delete = false

в файле po3_Tweaks.ini
Аватар viconia
viconia в 12:59:00, 07.08.2022
Там похоже все надо умножить на ноль) Честно говоря вообще не понимаю что он там исправляет, все и без него прекрасно работало.
Аватар utimusipusi2
utimusipusi2 в 23:11:37, 07.08.2022
фиксом powerofthree's Tweaks исправляются ошибки, на которые вы можете даже не обращать внимания и не считать их "ошибками", например
+Применяет эффект искажения голоса к NPC в шлемах, закрывающих лицо.
поэтому можно смело сказать что это "излишние" исправления
Что нелзя сказать об powerofthree's Papyrus Extender, который добавляет ОЧЕНЬ полезный функционал в моды!
Аватар k©קaso√®
k©קaso√® в 20:12:21, 05.08.2022
№38, Администратор
Обновление:5.2.0
* Что обновлено или изменено пока не известно, автор не предоставил список обновления, как появится, добавлю.
Аватар utimusipusi2
utimusipusi2 в 22:22:27, 05.08.2022
Копасыч, убери пожалуйста powerofthree's Tweaks из "требуемых", он "рекомендованный". а то народ это смущает)) (что он требуемый!)
Аватар k©קaso√®
k©קaso√® в 11:01:31, 24.06.2022
№37, Администратор
Обновление:5.1.1
[События] Исправлена ​​ошибка, из-за которой использование ключевых слов в OnHitEx и OnMagicEffectApplyEx могло привести к тому, что события не срабатывали.
Аватар Lyrfox
Lyrfox в 17:13:26, 15.05.2022
Работает должным образом  эта версия мода с Frozen Electrocuted Combustion версии: 4.9.6. , кто ни будь проверял т к предыдущая версия - не работала ???  У меня , при загрузке игры требует версию 4.5. ... , может у кого то по другому ???  questionmark
Аватар Sarol
Sarol в 20:41:29, 15.05.2022
Обнови версию с nexusmods v5.0.5
Аватар Lyrfox
Lyrfox в 09:38:40, 16.05.2022
Новая версия требует начала новой игры ( или новое сохранение , что не гарантирует работу ) ... Вас понял - установил патч совместимости новой версии Папируса и FEC 4.9.6 ( заработало ) !!! Вельми благодарен  respect
Аватар Sarol
Sarol в 10:20:00, 16.05.2022
Удалить мод, очистить save, потом сохранится, установить новый.
Аватар Lyrfox
Lyrfox в 12:30:21, 16.05.2022
Вот уже и должно всё заработать - а не тут то было , этот Папирус ещё тот коварный партнёр... т к есть моды под его прошлые версии ( такие , как на  снижение массы предметов ) и при загрузке старых сохранок  вес изменяется , да ещё в добавок надетые предметы брони , такие как чёккер ( зачарованные на снижение переносимого веса ) - не персе не отображаются и чары не работают ... так что не все новшества хороши , а при установке патча на Папирус - ещё и время загрузки увеличилось ( это уже технические моменты ) ( как в той поговорке - Не буди лихопока оно тихо) ...
Аватар k©קaso√®
k©קaso√® в 11:05:04, 15.05.2022
№31, Администратор
Обновление:5.1.0
[Актёры] Добавлен параметр GetEquippedWeaponPoison и связанные с ним функции.
[Обнаружение] IsDetectedByAnyone — пропускает актеров (НПС) с флагом DoesntAffectStealthMeter.
[События] Добавлен параметр RegisterForHitEventEx (событие попадания с пользовательскими фильтрами, аналогично OnMagicEffectApplyEx).
[События] Добавлены формы уникальных событий (например, RegisterForMagicEffectApplyEx, для этого требуется скрипт, расширяющий ObjectReference).
[Фракция] Добавлен параметр GetVendorFactionContainer.
[Ссылочные данные на объект] Добавлен параметр RemoveAllModItems.
[Общее] Документация теперь доступна в удобном для чтения формате на вики, указанной в описании.
[Общее] Внесена незначительная оптимизация.
Аватар Faaaaaiile
Faaaaaiile в 17:53:05, 13.05.2022
у меня ошибка 

po3_PapyrusExtender.dll

Rel/relocation.h(473): Failed to obtain module handle for: "SkyrimSe.exe"
Аватар Indexto
Indexto в 17:08:39, 15.04.2022
Кто-то может объяснить, у меня Скайрим СЕ, при установке 5 версии этого мода - вылет при загрузке сохранений. При этом на 4.5.7 работает спокойно
Аватар k©קaso√®
k©קaso√® в 12:42:09, 13.04.2022
№28, Администратор
Обновление:5.0.3
[Общее] Варианты для Skyrim SE 1.5.97.0.8 и Skyrim AE 1.6.ххх теперь в одном общем установщике с вариантами выбора.
[Свет] Исправлены некоторые отсутствующие сбросы флагов в параметре SetLightType.
[События] Временно отключено событие SpellLearned в версии AE 1.6, так как оно приводило к сбою игры при определенных обстоятельствах.
Аватар Lyrfox
Lyrfox в 20:05:21, 08.04.2022
И да , на новой версии при запуске появляется окно с требованием обновить мод FEC в связи с обновлением Папируса ... !!!  oops
Аватар MaxysT
MaxysT в 11:58:08, 08.04.2022
Такими темпами и FEC наконец-то обновят, а то аж непривычно без горелых трупиков  tongue
Аватар k©קaso√®
k©קaso√® в 11:06:24, 08.04.2022
№24, Администратор
обновлено 5.0.2 для Skyrim AE и SE
Аватар Robin_Hood
Robin_Hood в 16:12:03, 12.04.2022
Версия 5.0.2 не работает должным образом с Frozen Electrocuted Combustion версии: 4.9.6. Автор в будущем обещает сделать патч совместимости. Для во избежание неразберихи можно сделать ссылку на версию powerofthree's Papyrus Extender SE 4.5.7
Аватар k©קaso√®
k©קaso√® в 12:21:24, 12.01.2022
№23, Администратор
обновлено 4.5.7 для Skyrim AE и SE
Аватар k©קaso√®
k©קaso√® в 19:00:53, 01.12.2021
№20, Администратор
обновлено 4.5.5 для Skyrim AE и SE
Аватар evgen76
evgen76 в 19:04:21, 02.12.2021
Объясни пожалуйста обязательно нужно его обновлять? К сожалению мне как рядовому юзеру описание ничего не говорит.
Аватар k©קaso√®
k©קaso√® в 19:21:01, 02.12.2021
№22, Администратор
ну так как этот плагин является фреймворком, то есть ядром на основе которого работают другие моды, то да, лучше обновлять всегда, потому что в новых версиях исправляются какие то данные, на основе которых работают другие моды, если они у вас есть, посмотрите список модов которые требуют этот плагин, а так то сам по себе данный плагин вообще в игре ничего не делает, оне нужен для работы других модов из списка в опсиании. Обновить просто, скачать, установить в игру с заменой всех файлов, играть, больше с вашей стороны ничего не нужно делать.
Аватар Fierce2005
Fierce2005 в 23:50:22, 24.11.2021
Будет ли вообще обновление для 1.6.323 от автора?
1 2 »
avatar
Gamer-mods.ru © 2012 - 2022. Все права защищены. Копирование материалов без указанной активной ссылки на данный сайт запрещено.