PapyrusUtil SE - Modders Scripting Utility Functions

06.04.2018 k©קaso√® Инструментарий 6660 19 Загрузок:2345

Автор:exiledviper meh321
Версия:3.4b
Перевод:не требуется

Описание:
Этот плагин PapyrusUtil SE является ресурсом для мододелов и для создания некоторых модов для игры Skyrim SE, которые вынуждены иметь данное ядро/плагин для функционала и работы модов. Этот SKSE64 плагин позволяет сохранять любое количество int, float, form, string и строковых значений из скриптов папируса. Также поддерживает списки всех типов данных. Эти значения могут быть доступны из любого мода, позволяющие легко динамически сделать совместимость. А также, многие игроки сталкивались с такой ошибкой, когда при входе в игру через SKSE64 показывается уведомление, в котором написано "Устаревший или отсутствующий Papyrus Util плагин для SKSE64", это значит что у вас не установлены некоторые крайне важные скриптовые файлы и dll. для корректной работы некоторых модов, которые имеют привязку к SKSE64. Этот плагин называется "PapyrusUtil", он разработан в основном для мододелов, чтобы использовать данный плагин в своих модах, некоторые моды как раз и требуют наличие этого плагина для работы функционала.

Обновление:3.4b
- Добавлена поддержка для игры версии 1.5.39.0.8 и SKSE64 SE 2.0.7
- Скрипты продублированы и скопированы по пути /source/scripts для тех кто пользуется Creation kit.

Обновление:3.4
- Добавлены обратно функции связанные с TFC.
- Добавлены обратно функции переопределения пакета ActorUtil.
- Исправлена пр

облема с формами (forms), иногда хранящими / возвращающими неправильно, в то время как файл .esl активен в порядке загрузки модов.Обновление:3.3с
- Добавлена поддержка для игры версии 1.5.23.0.8 и SKSE64 SE 2.0.6

Обновление:3.3b
- Добавлена поддержка для игры версии 1.5.16.0.8 и SKSE64 SE 2.0.5
- Добавлен функционал MiscUtil.SetMenus()

ПРИМЕЧАНИЕ:
Функционал скриптов ActorUtil и ObjectUtil были отключены в версии SE. Первоначально эти функции требовали редактирования некоторых функций памяти, и мне не хватает инженерного опыта, чтобы иметь возможность снова работать с этими функциями в 64-разрядной версии.

Требования:
Skyrim SE 1.5.3.0.8 и выше
SKSE64 SE 2.0.4 и выше

Совместимость:
- Совместим со всем

При обновлении до 3.4b:
- Удалите файл PapyrusUtil.pdb по адресу Data/SKSE/Plugins/
- Установите новую версию с заменой всех остальных файлов

Установка:(можно вручную или через NMM/MO менеджеры)
Берем все содержимое из папки Data в архиве и помещаем в папку Data в игре, подтвердите слияние папок и файлов если потребуется.

По осн.ссылке "Для игры 1.5.39.0.8" (требуется skse64 2.0.7)
По доп.ссылке "Для игры 1.5.23.0.8" (требуется skse64 2.0.6) не обновляется и не поддерживается

По доп.ссылке "Для игры 1.5.16.0.8" (требуется skse64 2.0.5) не обновляется и не поддерживается
По доп.ссылке "Для игры 1.5.3.0.8" (требуется skse64 2.0.4) не обновляется и не поддерживается

Skyrim SE, SKSE64, инструментарий, Скайрим, PapyrusUtil SE, плагин

Если архив не распаковывается, пустой, выдает ошибки, то обновите свой архиватор до последней версии. Если архив не скачивается, то сообщите о проблеме релизеру мода.

Всего комментариев: 19
avatar
1
19
Обновление:3.4b
- Добавлена поддержка для игры версии 1.5.39.0.8 и SKSE64 SE 2.0.7
avatar
2
16
Обновлено 3.4
avatar
0
15
Про NiOverride  ничего не слышно?
Жду фикс высоких каблуков для него ))
avatar
0
17
если вы имеете ввиду NiOverride про RaceMenu, то он в разработке
avatar
0
14
На прошлой версии решал проблему с предупреждением от Переносных фонарей от Chesko. В новой версии опять эта хрень вылезает. Как так?
avatar
2
13
Обновление:3.3с
- Добавлена поддержка для игры версии 1.5.23.0.8 и SKSE64 SE 2.0.6
avatar
4
12
Обновление:3.3b
- Добавлена поддержка для игры версии 1.5.16.0.8 и SKSE64 SE 2.0.5
- Добавлен функционал MiscUtil.SetMenus()
avatar
2
8
Наверное стоит указать в описании, что эта версия мода урезана автором. Он не смог перенести некоторые функции из версии для ле, такие как свободная камера и многие другие.
avatar
2
9
добавил
avatar
0
10
А какие именно функции урезаны кроме свободной камеры? Где можно посмотреть?
Вот же засада, и тут ещё не всё. 
avatar
0
2

Это к посту №1
avatar
1
3
Ну это пока. Всё в муках рождается. Там-же про RaceMenu для SSE, правильно?
NiOverride и в LE не совсем доделан. Особенно что касается оверлеев для лица. Вылеты при обезглавливании изрядно доставали.
avatar
0
4
Racemenu, UIExtensions и NiOverride - тот же автор. Он, кстати, на днях скинул наполовину рабочую версию (как говорят) Рейсменю и функциональный HUD для SE, пока что так. Могу дать ссылку в ЛС. wink
avatar
0
5
RaceMenu пусть пилит, а что за функциональный HUD?
avatar
0
6
Понятия не имею, у меня LE.
Ха, "пусть Рейсменю пилит"... А с Фоллом что будет? Он главный разработчик F4SE, да и Looksmenu дошлифовывать надо. А вдруг Беседка опять патч выдаст, а он в Скае? biggrin
avatar
0
7
хех, пусть крутится как юла biggrin
avatar
0
18
а зачем ждать RACEMENU - если есть ЕСЕ ? не понимаю , вам скайрим нравиться или какие-то пару модов с оч уважаемыми авторами ?
avatar
3
1
Ещё один ключевой плагин для SE. Спасибо!
Осталось дождаться UIExtensions и NiOverride.
avatar
0
11
UiExtension у меня от старого Ская работает а для AddItemMenu автор выложил обновлённый dll. Сказал что целиком доделает как будет готово RaceMenu.
Извещения об обновлениях
avatar
.......
Таверна
Наши каналы
Друзья сайта
Последние комменты
14:43:54
Basil44
14:42:00
asgarott
Создать самому в папке Data/SKSE, либо скачать уже готовый 24.04.2018
14:40:07
comfort-m
Конечно не обязаны, это, всего лишь, показывает ваше отношение к работе (за которую вы, кстате, прос...
О какой хорошенький, забираю happy...
14:36:49
Аббат
А еще вопрос: где этот SKSE.ini находиться?
14:14:48
asgarott
Модульная версия старая очень, давно не обновлялась автором, еще более конфликтная чем эта. Да и оши...
14:12:35
Гризл
Кош...не разгорайся сердцем...МЫ тебя ценим и любим...)
...а у девочки...просто...гормоны...)...
14:08:29
k©קaso√®
никак, оно прибито к телу вроде
А...поняла, этот голем вошел в первую сборку Мишиных модов. 24.04.2018
13:57:21
Plan
Крутой мод, жаль, что очень конфликтный. Даже ставить боюсь.