Расширенный диалоговый интерфейс / Extended Dialogue Interface (XDI)
04.10.2018 37549 10286 Автор: registrator2000 Локализатор: k©קaso√® Версия: 1.3.1 Перевод: Русский

Расширенный диалоговый интерфейс / Extended Dialogue Interface (XDI)

В оригинале игры Fallout 4, в диалогах игрока имеется ровно четыре варианта ответа/диалогов - игра не может использовать их ни больше, ни меньше. Эта игровая диалоговая система также включает в себя большинство диалогов в один из четырех типов: Да, Нет, нейтрально и вопрос. Как вы можете видеть, что диалоги не всегда укладываются в эти 4 категории! Данный мод Extended Dialogue Interface (XDI) - это платформа (ядро), которая удаляет жестко закодированные 4-х вариантные ограничения для диалогов и добавляет в движок игры поддержку для любого количества вариантов диалога игрока. Модмейкеры в своих модах теперь могут создавать/добавлять новые диалоги, которые подчеркивают выбор игрока и имеют варианты диалогов, которые действительно отражают их намерения. XDI не изменяет игровые диалоги самостоятельно, но будет отображать полнотекстовые варианты выбора игровых диалогов, то есть с данным модом все игровые диалоги тоже изменятся. Самое интересное то, что в нескольких игровых сценах, Bethesda добавили дополнительные варианты записанных диалогов! Во многих случаях они не правильно подключаются к XDI (не связанные ответы и т.д.), поэтому их нельзя просто включить в глобальном масштабе. Тем не менее, модмейкеры могут модифицировать такие игровые диалоговые сцены, чтобы правильно соединить их и выставить дополнительные озвученные диалоговые линии, которые уже являются частью базовой игры.

Обновление:1.3.1
- Добавлен вариант мода для игры версии 1.10.114.0

Обновление:1.3.0
- Добавлен вариант мода для игры версии 1.10.111.0
- Что-то еще автор добавил, какой-то новый функционал, но я не понял что имеется ввиду "Say Once functionality for player and NPC dialogue in XDI-enabled scenes is now supported.", если кто понял смысл этой фразы, то напишите мне.

Обновление:1.2.4
- Добавлен вариант мода для игры версии 1.10.106.0

Журнал изменений:
- Добавлен вариант мода для игры версии 1.10.98.0
- Обновлен вариант мода для игры версии 1.10.89.0
- Обновлен вариант мода для игры версии 1.10.82.0
- Обновлен вариант мода для игры версии 1.10.75.0
- Новое: плагины теперь могут указывать собственное ключевое слово активации XDI.
- Исправлено: файл мода теперь правильно помечен как ESM формат, поэтому будет правильно размещаться в списке загрузки модов. Ранее файл мода тоже имел формат ESM, но был помечен как ESP.
- Добавлен вариант мода для игры версии 1.10.75.0
- Исправлено: менеджер модов в самой игре больше не будет автоматически отключать мой мод XDI (это раздел Модификации в меню игры).
- Обновлен вариант мода для игры версии 1.10.64.0, обновлены внутренние адреса в файле XDI.dll
- Добавлен вариант мода для игры версии 1.10.64.0
- Добавлен вариант мода для игры версии 1.10.50.0
- Добавлен вариант мода для игры версии 1.10.40.0
- Исправлено: ответы NPC, которые связаны с квестами, больше не будут вызывать вылет игры.
- Новое: возможность выбора параметров диалога с помощью цифровых клавиш.
- Новое: новая опция в МСМ меню для отображения цифры перед вариантами диалогов.
- Новое: новые параметры настроек в МСМ меню для отображения скобок и фона диалогового меню.
- Новое: значки подсказок диалогов обмена и инвентаризации для ванильных диалогов.
- Улучшено распознавание следующей темы. Больше вариантов диалогов теперь будут иметь диалоговые подсказки (значки).
- Исправлено диалоговое меню теперь будет отображаться правильно при разговоре с не NPC (например, Интерком).
- Исправлено диалоговое меню теперь будет правильно открываться при загрузке сохраненной игры.
- Исправлена проблема в некоторых сценках, где диалоговое меню показывалось пустым.
- Подкорректирован перевод в МСМ настройках.

Особенности мода:
* Полный текст диалога. Просмотрите свои варианты диалога с полной уверенностью в том, что вы собираетесь сказать.
* Диалоговые подсказки. Значок вопроса может быть дополнительно отображен для параметров диалога, которые не продвигают разговор далее. Не будет больше случайного выбора, когда все, что вам нужно, - это получить дополнительную информацию. Параметры, которые заканчивают разговор, будут отображаться рядом с ними.
* Гибкие варианты диалогов. Есть меньше чем четыре вещи, чтобы сказать в ответ? Тогда у вас есть только два варианта. Или добавьте столько вариантов, сколько захотите и у вас будет больше чем 4 варианта ответов и диалогов.
* Нет голоса у игрока, нет проблем. В играх Skyrim и Fallout New Vegas тоже не было озвучки у игрока! Данный мод XDI вносит изменения в движок чтобы это "преодолеть". Для не озвученных диалогов игрока, диалоги NPC начинаются сразу после выбора опции. Диалоговая камера исправлена, чтобы сосредотачиваться на NPC вместо (в оригинале игры) осмотра на неподвижный рот игрока. Больше никаких неловких пауз.
* Настраиваемое меню MCM. Мод XDI поставляется с меню MCM для легкой настройки.
* Никаких взломов. Эти изменения интегрированы в движок - нет необходимости в обходных решениях, «пустых голосовых файлах», исправлении файлов локализации STRINGS и т.д.
* У игровых компаньонов начальное диалоговое меню будет стандартное круговое, но далее при выборе диалоге в круговом меню, уже будут строчные диалоговые линии из мода с вариантами выбора, почему так сделано не понятно.

Для модмейкеров:
* Если вы сами делаете моды и хотите изменить диалоги для работы с этим модом, то здесь есть инструкция.

Требования:
Fallout 4 version 1.10.114.0 (требуется F4SE 0.6.13)
Fallout 4 version 1.10.111.0 (требуется F4SE 0.6.12)
Fallout 4 version 1.10.106.0 (требуется F4SE 0.6.11)
Fallout 4 version 1.10.98.0 (требуется F4SE 0.6.10)
Fallout 4 version 1.10.89.0 (требуется F4SE 0.6.9)
Fallout 4 version 1.10.82.0 (требуется F4SE 0.6.7)
Fallout 4 version 1.10.75.0 (требуется F4SE 0.6.6)
Fallout 4 version 1.10.64.0 (требуется F4SE 0.6.5)
Fallout 4 version 1.10.50.0 (требуется F4SE 0.6.4)
Fallout 4 version 1.10.40.0 (требуется F4SE 0.6.3)
Fallout 4 version 1.10.26.0 (требуется F4SE 0.6.0)
Mod Configuration Menu соответствующей версии для вашей версии игры

Совместимость:
* Я лично (локализатор) проверял совместно с модом DEF_UI и оба мода прекрасно работают вместе.
* С модом Full Dialogue Interface логично что не совместим, так как в обоих модах изменения касаются интерфейса диалоговых ответов.
* Не совместим с любым модом который имеет файл DialogueMenu.swf по пути Data\Interface\DialogueMenu.swf, если у вас есть такой файл в игре, то удалите его, так как такой же файл DialogueMenu.swf есть в этом моде в файле .ba2, а как известно, любые файлы которые не в .ba2, переопределяют те что в .ba2

При обновлении с 1.0 до 1.3.1 и выше:
- Чтобы обновиться, просто замените и перезапишите старые файлы. XDI может быть безопасно обновлен в любое время.

Установка:(можно вручную или через менеджеры модов)
0. Скачайте общий архив, в нем имеются варианты мода для разных версий игры:
Для игры 1.10.114.0 - 1.3.1
Для игры 1.10.111.0 - 1.3.0
Для игры 1.10.106.0 - 1.24
Для игры 1.10.98.0 - 1.23
Для игры 1.10.89.0 - 1.22
Для игры 1.10.82.0 - 1.21
Для игры 1.10.75.0 - 1.20
Для игры 1.10.64.0 - 1.14b
Для игры 1.10.50.0 - 1.13
Для игры 1.10.40.0 - 1.12
Для игры 1.10.26.0 - 1.11
1. Выбрать нужный вариант архива, берем все содержимое из папки Data в архиве и помещаем в папку Data в игре, активировать мод. В моде формат файла .esm, поэтому данный мод размещать в списке порядка модов выше всех модов у которых формат .esp, но ниже файла .esp от неофициального патча.
2. В игре идем в Настройки модов и настраиваем нужные опции данного мода.
3. Если вы получите сообщение об ошибке загрузки плагина XDI, проверьте, установлен ли и запущен F4SE!

Внимание: Автор данной темы, имеет право удалять комментарии по своему усмотрению, если комментарии не соответствуют правилам сайта.
1 2 3 4 5 »
Аватар fallout555777
fallout555777 в 18:59:32, 15.12.2018
1.32 вышла.обновить бы. https://www.nexusmods.com/fallout4/mods/27216/
Аватар sumrak7676
sumrak7676 в 00:50:10, 13.11.2018
Сделайте что-то на 1.9.4 Fallout!!!
Сторонние моды просят XDI, в противном случае вместо диалогов запускают окно "FASE -ok; XDI - FAILED"
Нужно возможно какая то версия XDI которая будет обманывать что она XDI и по факту будут те же ванильные выборы диалогов.
Аватар ROCKBOURNE
ROCKBOURNE в 17:58:07, 09.12.2018
Появилась новая версия на нексусе 1.3.2.
Аватар bez
bez в 22:57:52, 12.11.2018
Привет а для игры 1.9.4  какой мне надо ?
Аватар sumrak7676
sumrak7676 в 00:50:38, 13.11.2018
Поддержу. Какой???
Аватар k©קaso√®
k©קaso√® в 12:42:12, 04.10.2018
№147, Администратор
Обновление:1.3.1
- Добавлен вариант мода для игры версии 1.10.114.0
Аватар k©קaso√®
k©קaso√® в 21:42:36, 30.08.2018
№146, Администратор
Обновление:1.3.0
- Добавлен вариант мода для игры версии 1.10.111.0
Аватар Kurier01
Kurier01 в 16:52:41, 30.08.2018
Под новую версию фолла есть?
Аватар mrsunshine
mrsunshine в 17:22:04, 17.08.2018
Спасибо.
Аватар colt47pc
colt47pc в 05:32:56, 29.07.2018
Цитата colt47pc;142 ()
Блин, вот бы можно было совместить с фулл диалог интерфейс, ну или убрать фон и обводку, оставив лиш цифры, текст, ну и значки. Ну или на оборот добавить в ФДИ значки эти) Штука полезная но не нравится как выглядит
Разобрался, оказывается есть все эти настройки в моде, сорян.
Но возникла проблема - в разговоре со спутниками осталось старое диалоговое окно как будто из ФДИ только без моих параметров (т.е. со скобками и затемнением на фоне), мб кто сталкивался из за чего это может быть? Есть подозрения на ваулт-герл мод...
Аватар colt47pc
colt47pc в 05:12:32, 29.07.2018
Блин, вот бы можно было совместить с фулл диалог интерфейс, ну или убрать фон и обводку, оставив лиш цифры, текст, ну и значки. Ну или на оборот добавить в ФДИ значки эти) Штука полезная но не нравится как выглядит sad
Аватар k©קaso√®
k©קaso√® в 09:31:45, 27.07.2018
№141, Администратор
Обновление:1.2.4
- Добавлен вариант мода для игры версии 1.10.106.0
Аватар MrFrin
MrFrin в 15:53:50, 26.07.2018
У меня Fallout 4 версии 1.10.89. У неё версия Меню настройки модов 1.27. Здесь максимальная требуемая версия Меню настройки модов 1.25. Вопрос: надо ли мне устанавливать Меню настройки модов?
Аватар k©קaso√®
k©קaso√® в 16:11:50, 26.07.2018
№140, Администратор
естественно надо, чтобы МСМ был соответствующей новой версии для вашей версии игры
Аватар Serj
Serj в 09:58:40, 30.06.2018
При совместном использовании переведенной версии с AAF, игра намертво зависает в первые минуты после запуска. С оригинальной версией проблем нет.

п.с. Виновником зависаний оказался совсем другой мод - https://www.nexusmods.com/fallout4/mods/22105/?tab=posts
Аватар BJIADICJIAB1
BJIADICJIAB1 в 16:41:11, 24.06.2018
Мод полезный, но по неизвестной мне причине ру версия виснет. Игра просто намертво зависает и приходится перезапускать игру. Версия с Нексуса такой проблемой не страдает и текст (диалоги) самое главное на русском. В общем, если у Вас та же проблема что и у меня, качайте версию с Нексуса!
Аватар middim
middim в 16:32:31, 20.06.2018
У меня игра зависает, при разговоре с начальным роботе, о 200 лет прошло и т.д
И это только начало, как будет дальше, неизвестно
Установил с Нексуса, зависания нет. Какой-то косяк с русификацией.
Аватар bluden
bluden в 21:43:07, 08.06.2018
Почему то не работает.
1 2 3 4 5 »
avatar
Gamer-mods.ru © 2012 - 2018