Backported Extended ESL Support / Расширенная поддержка ESL с бэкпортом (исправление работы модов созданных в новом Creation Kit)
10.12.2023 2038 453 Автор мода: Nukem Автор публикации: k©קaso√® Версия: 1.2 Перевод: Мультиязычный

Backported Extended ESL Support / Расширенная поддержка ESL с бэкпортом (исправление работы модов созданных в новом Creation Kit)

Добавляет поддержку плагинов формата .ESP, .ESL, .ESM), представленного в версии игры Skyrim AE 1.6.1130 и выше, для версий игры Skyrim от 1.5.97 до 1.6.640-1.6.659 (GOG) и всех промежуточных версий.
Backported Extended ESL Support повторяет обновленный код загрузки плагина, используемый в патче 1.6.1130 Skyrim АЕ. Это позволяет старым версиям игр беспрепятственно загружать новые файлы плагинов, созданных в обновленном Creation Kit.

ВАЖНО!!! Не устанавливайте этот плагин, если вы используете версию игры 1.6.1130 или новее. Это излишне.

Что это вообще такое и зачем?
* 5 декабря 2023 года Bethesda выпустила обновление 1.6.1130 (1.6.1170) и обновленный Creation Kit для Skyrim АЕ. Это не только нарушило совместимость с модами SKSE, но также нарушило совместимость с плагинами (.ESP, .ESL, .ESM), увеличив версию их заголовков с 1.70 до 1.71. Попытка использовать плагин версии 1.71 в старой версии игры (которые были до 1.6.1130), скорее всего, приведет к сбою. Так почему же они это сделали, чтобы увеличить максимальное количество новых записей данных в ESL с 2048 до 4096. См. этот пост на Reddit для подробного объяснения https://old.reddit.com/r/skyrimmods/comments/18btob5/updated_information_about_the_new_skyrim_update/
В итоге, моды, созданные в последнем обновлении Creation Kit, будут несовместимы ни с какой другой версией игры которые ниже чем 1.6.1130, с этим плагином моды которые будут создаваться в обновленном Creation Kit, будут работать в любой версии игры ниже чем 1.6.1130

Журналы логов:
Диагностическая информация записывается в файл BackportedESLSupport.log по пути Documents\My Games\Skyrim Special Edition\SKSE\, где перечислены все соответствующие плагины.

Требования:
Skyrim SE-AE от 1.5.97 до 1.6.640-1.6.659 (GOG)
Address Library for SKSE Plugins SE / Address Library for SKSE Plugins AE
Skyrim Script Extender (SKSE64) SE / Skyrim Script Extender (SKSE64) AE

Установка:
Скачать архив плагина и установить через менеджеры или вручную, активация не требуется.
Внимание: Автор данной темы имеет право удалять комментарии пользователей, если комментарии не соответствуют правилам сайта. Если ВЫ как пользователь считаете, что ваш комментарий был удален без каких-либо на то причин и без основания, то можете написать автору данной темы, и спросить, за что был удален ВАШ комментарий, с предоставлением причины удаления, исходя от правил сайта.
Аватар Dusha_Volka
Dusha_Volka в 15:11:16, 13.04.2024
Нравится
Этот мод, штука хорошая, но он нарушит два мода точно, это то что я заметила в своей сборке (не то что бы совсем не играбельно, но для меня это критично) Моргание глазами и с модом Go to bed ГГ будет спать с открытыми глазами.  ЭТОТ БАГ лечится ВОТ ЭТИМ! ставить через МО2  так что бы ЭТОТ Mfg Fix был выше в списке загрузки !!! Приятной игры!     Всё работает, лично проверила!
Беседка, тонко намекнула "Вот вам лимит ещё больше на моды, шестые свитки лучше не ждать" 
Аватар brutalpadla
brutalpadla в 20:43:45, 20.03.2024
Нравится
Люди , а как можно файл созданный в новом creation kit , загрузить в старый creation kit ?
Аватар Slymeph
Slymeph в 19:39:08, 27.01.2024
Нравится
Значит ли это, что на прошлую версию ская можно поставить последний USSEP?
Аватар Lyrfox
Lyrfox в 19:13:10, 10.12.2023
Нравится
Как я понял - данная прога нужна для Скайрим АЕ и пользователей  Криэйшн Кит , но тогда в требованиях зачем пишется Скайрим СЕ ??? meeting
Аватар k©קaso√®
k©קaso√® в 19:18:45, 10.12.2023
№2, Администратор
Нравится (1)
это не прога а плагин, который заставит работать моды в старых играх СЕ 1.5.97 и АЕ 1.6.ххх, которые будут сделаны в новом обновленном Креатоне Кит, который вышел вместе с обнрвлением АЕ 1.6.1130, без этого плагина моды просто не будут работать в старых версиях игры СЕ и АЕ которые идут до версии 1.6.1130
Аватар newgene
newgene в 19:29:53, 10.12.2023
Нравится (2)
Этот SKSE-плагин нужен для всех, у кого любая версия Skyrim предшествующая 1.6.1130, в том числе и 1.5.97 (она же SE, pre-AE), чтобы игра могла верно загружать плагины, созданные в последней версии Creation Kit с HEDR 1.71.
Пока ещё таких плагинов совсем мало, но со временем будет всё больше. Например, новые моды и обновления 4thUnknown и Arthmoor уже c HEDR 1.71.

Любая попытка загрузить плагины из нового Creation Kit в версии GOG, AE 1.6.640 или SE 1.5.97 приведёт или к CTD, или к совершенно непредсказуемым багам, так как из-за ошибки считывания FormID может произойти замена записи, например, ГГ на модель ведра из нового плагина и игра просто не поймёт, что с этим вообще делать.
avatar
Gamer-mods.ru © 2012 - 2024. Все права защищены. Копирование материалов без указанной активной ссылки на данный сайт запрещено.