Универсальный патч совместимости для 1.31 GOTY и 1.32-1.31 не-GOTY / Unification patch for 1.32-1.31 - 1.31GOTY
29.01.2017 13632 1722 Автор: wghost81 Локализатор: k©קaso√® Версия: 1.1 Перевод: Русский

Универсальный патч совместимости для 1.31 GOTY и 1.32-1.31 не-GOTY / Unification patch for 1.32-1.31 - 1.31GOTY

Универсальный патч совместимости для 1.31 GOG GOTY и 1.31 GOG/Steam не-GOTY версий игры

Данный патч изменяет БАЗОВЫЕ скрипты и делает не-ГОТИ и ГОТИ версии одинаковыми:

- главное меню будет случайным как в ГОТИ.
- не-ГОТИ получит небольшой фикс уровня предметов в НИ+, доступный только в ГОТИ версии.
- сообщение "DLC такое-то установлено" больше не будет появляться при загрузке сохранения.
- приветственное сообщение в главном меню больше не будет показываться (не относится к ГОТИ, нужно для совместимости).
- баннеры "DLC установлено" в главном меню больше не будут показываться, если у вас есть оба платных DLC.
- ГОТИ получит опцию "Загружаемый контент" в главном меню, где будут отображаться все установленные DLC.
- и самое главное: базовые скрипты обеих версий игры будут идентичны, что существенно облегчить жизнь как модмейкерам, так и пользователям модов.

Требования:
- 1.31 GOG GOTY: часто называемая просто "ГОТИ", распространяется только через платформу GOG.
- Steam 1.31 GOTY: набор, куда входит базовая версия 1.31 и все DLC.
- Steam/GOG 1.32-1.31: обычная версия игры, часто называемая "не-ГОТИ".
* Т.е. проще говоря, существуют две версии игры: 1.31 GOG GOTY ("ГОТИ") и 1.32-1.31 ("не-ГОТИ").
* ГОТИ и не-ГОТИ почти одинаковы, но разница между ними достаточна для появления проблем с модами.

Зачем нужен данный патч:
- Главный источник конфликтов между ГОТИ и не-ГОТИ - это код относящийся к меню. Проблема в том, что код, который относится к меню, не ограничен только скриптами меню, он находится ещё и в файле r4game.ws, который может использоваться модами не относящимися к меню даже отдалённо (например, моды на получаемый опыт). Природа изменений меню в ГОТИ такова, что автоматически конфликты в Script Merger не разрешаются, а полуавтоматическое разрешение с ручной подстановкой конфликтных строк создаёт неработающий скрипт, если пользователь не знаком со скриптовым языком TW3. Если у вас есть такая проблема, то установка данного патча позволит её решить.

- Имейте ввиду, что некоторые моды по-прежнему не будут объединяться автоматически, но конфликты будет решить проще:
* Ищите ключевые слова, такие как GOTY message, DLC available, NG+ available, menu type в объединяемых скриптах в местах конфликта и всегда выбирайте A (базовая игра) и обязательно следите за тем, чтобы код вокруг конфликтной области также повторял код из A (при необходимости удаляйте автоматически вставленные строки из B и C).

Установка:
1. Скачать "Unification patch" 1.1 - это сам патч
2. Для установки патча скопируйте папки "content" и "Mods" в папку <Путь куда установлена The Witcher 3> с заменой файлов.
3. Объедините заново все скрипты в Script Merger, если до этого у вас таковые имелись.

Удаление:
Если вы хотите вернуться к версии 1.31 не-ГОТИ, скачайте файл "Base 1.31 scripts" и скопируйте папку "content" в папку <Путь куда установлена The Witcher 3> с заменой файлов. Затем удалите папку mod0000____CompilationTrigger из
папки <Путь куда установлена The Witcher 3>\Mods. Объедините заново все скрипты в Script Merger, если до этого у вас таковые имелись.

Если вы хотите вернуться к версии 1.31 ГОТИ, скачайте файл "Base 1.31 GOG GOTY scripts" и скопируйте папку "content" в папку <Путь куда установлена The Witcher 3> с заменой файлов. Затем удалите папку mod0000____CompilationTrigger из папки <Путь куда установлена The Witcher 3>\Mods. Объедините заново все скрипты в Script Merger, если до этого у вас таковые имелись.

Внимание: Автор данной темы, имеет право удалять комментарии по своему усмотрению, если комментарии не соответствуют правилам сайта.
Аватар LexxProAktiv
LexxProAktiv в 08:00:47, 05.12.2018
Проверил данный патч и могу сказать,что игра наотрез отказывается запускаться.Как только сделал восстановление игры,то всё нормально стало,решил ещё раз поставить патч,и результат тот же -Игра отказывается запускаться.
Аватар Mr_Shersh
Mr_Shersh в 19:40:37, 16.04.2019
Установил сей патч на ГОТИ от Хатаба. Сверху стоит куча модов и Merged DLC. 

Игра спокойно нормально работает.
Аватар duke666x
duke666x в 11:11:07, 14.11.2018
Странно, но у меня из за этого патча игра переключалась на английскую озвучку, переключить обратно не возможно, только удаление помогало
Аватар Sckolver
Sckolver в 22:29:40, 09.07.2018
№3, Пользователь
Пропадает раздел модов в настройках, что делать?
Аватар Geniusssmit
Geniusssmit в 01:03:03, 14.08.2017
У меня есть в стиме ведьмак 3 без ДЛС, стоит ли покупать поверх него GOTY во избежания проблем, или можно обойтись Expansion pass и этим модом?
Аватар Azadan_Zenon
Azadan_Zenon в 22:52:33, 20.02.2017
Странная морковка. Переустановил своего франкенштейна - дисковая "нулевая" версия игры - последовательно патчи 1-й, 6-й, 10-й, 31-й - ДЛС. Думаю, кину этот апдейт. Не сработал, ошибка на этапе сборки скриптов, как обычно. Ради интереса откатил пакетом от Готи версии - запустилась, появилась смена главного меню. Бегло протестировал первым попавшимся скриптовым модиком. Работает он или нет проверять не стал, показалось достаточным того, что компиляция прошла удачно.
avatar
Gamer-mods.ru © 2012 - 2019. All rights reserved